Running bastille on debian lenny

After an upgrade from etch to lenny, the bastille firewall will not run any more:

  • Starting up will give you an error message about a missing /sbin/bastille-ipchains file
  • Reconfiguring (which would create that file) fails because DB5.0 is not supported

The problem: DB5.0 was not added to the supported OS lists in the debian lenny release.

The fix:

  • Add DB5.0 to the files: /usr/lib/Bastille/API.pm and /usr/lib/Bastille/IOLoader.pm
  • In API.pm change $stable=“4.0” to $stable=“5.0”
  • Run InteractiveBastille (your existing config file will be used to populate answers, no worries!)

After this, /etc/init.d/bastille-firewall start should work.

Ref:

~~LINKBACK~~

Enter your comment. Wiki syntax is allowed:
If you can't read the letters on the image, download this .wav file to get them read to you.